Provided deb package does not work on Ubuntu 19.10

Bug report

deb package fails to install on Ubuntu 19.10.
“Package ‘libgnome-keyring0’ has no installable candidate”

This means I cannot install the latest version via the deb package. And since the snap package is no longer supported, I’m stuck with an outdated version through snap.

Info

  • Pop!_os (based on Ubuntu)
  • 19.10
  • App Version: (4.4.0)

Reproduce

Attempt to install the deb file on Ubuntu 19.10 or a derivative.

Resolution 1

Update deb package to work with Ubuntu 19.10

Resolution 2

Please resume support for the Snap package. It makes installing the application simple, regardless of distribution.

Hi Daniel,

Thank you for the report.
I got it to work on Ubuntu 19.04 but it looks like the package libgnome-keyring0 no longer exists in the APT repository for 19.10:

https://packages.ubuntu.com/search?suite=eoan&arch=any&searchon=names&keywords=gnome-keyring

Maybe you can install it directly? https://launchpad.net/ubuntu/disco/+package/libgnome-keyring0

Let me investigate on how to solve that.

Related topic:

Is libgnome-keyring0 actually necessary? I was able to install the inkdrop deb manually with dpkg, and everything seemed to work fine. The only issue being that I could no longer install or upgrade anything, because every time I’d run apt it would detect that Inkdrop was missing a dependency.

I’ve got some reports that the app won’t work without libgnome-keyring0: https://forum.inkdrop.app/search?q=gnome-keyring
So I added it as a dependency.
But, yeah, I have the same question and that might depend on an environment.
Do you have gnome-keyring package installed?

I do have gnome-keyring installed.

I confirmed that it works fine without libgnome-keyring0 if the system has gnome-keyring on Ubuntu 19.10.
I will also check that on other Ubuntu versions.

I got it to work on Ubuntu 16.04 and Debian 9 as well.
Seems like having gnome-keyring is sufficient.
I will replace the dependency on libgnome-keyring0 with gnome-keyring from the next release.

You can try the patched deb package here: https://inkdrop-dist.s3-ap-northeast-1.amazonaws.com/tmp/inkdrop_4.4.0_amd64-patch-1.deb

Thanks!

You’re the best! Thank you.

This patch solved my problem as well (PopOS 19.10). Thanks!

1 Like

Released v4.4.1. Thanks, guys!
Also please check out the snap package which is being tested to be back available:

1 Like

Thanks alot! 4.4.1 is working nicely with ubuntu 19.10. - The demo link on your website is still linking to inkdrop_demo_4.4.0_amd64.deb (which has the issue)