Installed via snap but cant launch

(Dan Bohea) #1

Today I tried a fresh install of Inkdrop via snap on KDE NEon (Ubuntu 18.04). Launching via GUI seems to do nothing. Launching via cli throws the error:

app:info Quit because of duplicated instance +0ms

I’ve tried killing all inkdrop processes and launching the app again but I get the same every time. Searching this forum turned up a similar issue but one that predates installation via snap, the solution was to install various missing dependencies via apt but I would have thought that this was pointless for a snap installation?

(Takuya Matsuyama) #2

Hi Dan,

Thank you for the report.
I also have tried a fresh install on Ubuntu 18.04.1 recently and it worked fine without any additional package installation:

What dependencies were missing?

(Takahiro Kojima) #3

Hi, I faced to similar problem.

I gave up and used deb package. But error occured and this message make me install libgnome-keyring0.

I installed it by the following command:

sudo apt install libgnome-keyring-common  libgnome-keyring0

and then I succeeded in launching Inkdrop. Now I can use Inkdrop in snap store. Perhaps dpkg -i inkdrop.deb command may be a clue to know the necessary dependencies.

(Dan Bohea) #4

Yes, this is exactly what I ended doing in the end.

(Takuya Matsuyama) #5

That’s weird - libgnome-keyring0 is already a dependency of the snap package.
I’ll add about it to the docs. Thanks!