Electron App Question


(Joshua Douty) #1

Bug report

I’m having issues getting the linux app to run on Centos 7. I know compatibility is an issue on Centos7 but I’m also able to run other electron apps so it must be possible to get running.

Examples: Visual Studio Code, Slack, Mattermost, Tusk

Info

  • Platform: CentOS
  • Platform version: 7.6.1810
  • App Version: 4.0.0

Reproduce

  1. Be on CentOS 7

  2. Try to open inkdrop

    Error: /lib64/libstdc++.so.6: version `CXXABI_1.3.9’ not found


(Takuya Matsuyama) #2

Hi Joshua,

Thank you for the question.
I guess they build it on CentOS or other compatible distributions.
I build the app on Ubuntu 16.04 LTS and it seems that it affects some dependencies like libstdc++.
So I’m afraid that you can’t use it unless CentOS supports CXXABI_1.3.9.


(Joshua Douty) #3

Hey, sorry I didn’t mean to disturb your break! I just dropped it on here so I wouldn’t forget later.

Not being able to access my notes when I’m at work is tough. Overall I think you’ve got one of the best note-taking apps out there so I’m definitely going to keep watching this project and I’ll jump on board as soon as I’m not working on a CentOS machine anymore.


(Takuya Matsuyama) #4

Thank you for your understanding!