Constantly crashing on save v4.3.4/Win10 64-bit

Bug report

Inkdrop is crashing on save about 75% of the time. I tried turning off local sync, and uninstalling all plugins. It appears to only happen on larger notes. I’m currently working on one with 370 lines and it crashes pretty much every time I save. It will sometimes also crash when I re-open inkdrop several times before it loads the note. Unfortunately I can’t get a log from the console since it’s crashing. Is there an error log in the filesystem that I can attach to this bug report?

Edit: There are no images in any of my notes.


  • Platform: Windows 10
  • Platform version: v10.0.Build 18362
  • App Version: 4.3.4


Save a markdown note with over 300 lines of text.

Hi James,

Thank you for reporting it.
That’s weird. I have a longer note but I couldn’t manage to reproduce it.
To get logs of the main process, please run the app from Command Prompt like so:

Inkdrop.exe --enable-logging

I hope it will help you know what causes the problem.

I get this output in powershell when i run it:

[bugsnag] Loaded!
[26408:1003/234947.016:INFO:CONSOLE(3083)] "[bugsnag]", source: C:\Users\user\AppData\Local\inkdrop\app-4.3.4\resources\app.asar\node_modules\@bugsnag\browser\dist\bugsnag.js (3083)
[16412:1003/] Opening file:\C:\Users\user\AppData\Local\inkdrop\app-4.3.4\resources\app.asar: FILE_ERROR_FAILED
[16412:1003/] Opening file:\C:\Users\user\AppData\Local\inkdrop\app-4.3.4\resources\app.asar: FILE_ERROR_FAILED

Inkdrop starts as normal, but I’m not seeing any additional output or new logs in the filesystem when it crashes.

Edit: Another crash did generate some output:

[16412:1003/] Error sending sync broker message: The pipe is being closed. (0xE8)

Thank you for the log.
Looks like that’d be not related to your issue.
Does it happen on other notes?
I suspect that your note causes the problem not by its length but other reason.
If possible, could you send me your note via DM?

Hi, after a couple of restarts the problem appears to have gone away. Must have just been gremlins in the bits. :slight_smile:

1 Like

Good to hear that.
Yeah, I hope so.
BTW, I’m planning to update Electron in the next release and I hope it will solve some unreproducible issues like this!

Another data point for you, I’m also seeing this crash on v4.3.4/Win10 64-bit. Logs do not show anything happening on crash:

[bugsnag] Loaded!
[25388:1008/] rx::HLSLCompiler::compileToBinary(228):
C:\fakepath(46,8-58): warning X3571: pow(f, e) will not work for negative f, use abs(f) or conditionally handle negative values if you expect them
C:\fakepath(54,9-42): warning X3571: pow(f, e) will not work for negative f, use abs(f) or conditionally handle negative values if you expect them

[20324:1008/160636.618:INFO:CONSOLE(3083)] "[bugsnag]", source: C:\Users\alec\AppData\Local\inkdrop\app-4.3.4\resources\app.asar\node_modules\@bugsnag\browser\dist\bugsnag.js (3083)
[10056:1008/] Opening file:\C:\Users\alec\AppData\Local\inkdrop\app-4.3.4\resources\app.asar: FILE_ERROR_FAILED
[10056:1008/] Opening file:\C:\Users\alec\AppData\Local\inkdrop\app-4.3.4\resources\app.asar: FILE_ERROR_FAILED

The above logs appear immediately on startup. When I saved a file a few seconds later, the electron app just exited but no additional logs were added.

The crash happened three times in a row on first file save, but then stopped happening on subsequent reloads.

As with the above poster things seem to be working fine now after the first few crashes. I’ll update if the problem comes back.

Hi Alec,

Thanks for the report.
As I can’t reproduce it and no logs, I suspect it is an Electron’s bug.
I’ve released v4.4.0-beta.1 which is built with Electron 6.0.7 (The older versions were built with 3.1.4).
Please try it and see if it still happens.