Android hangs on loading

needs-reproduction

(Joe Narvaez`) #1

Bug report

Android hangs on loading. I can see my notebook on the side and make a note. But I can’t see any notes. Just the load spinner.

Info

  • Platform: (Android)
  • Latest Update July 9 2019

Reproduce

Open App

I already logged out and and reinstalled. Still no notes.


(Joe Narvaez`) #2


(Takuya Matsuyama) #3

Hi Joe,

Thank you for reporting it.
That’s weird. I need to reproduce it in order to solve it.
Can you please tell me what kind of device you are using and its Android version?


(Joe Narvaez`) #4

Pixel 2 and Android 9


(Takuya Matsuyama) #5

Hi,

Hmm, as you can see your notebooks synced, I guess it’s not a sync problem.
Does it also not work if you switched a notebook from side menu?
How about search?
I need to reproduce it but can’t at the moment.


(Takuya Matsuyama) #6

I added some debug code for the investigation. Can you please try it?

https://play.google.com/apps/testing/info.inkdrop

  • Version: 3.2.0
  • Version code: 37

(Joe Narvaez`) #7

I’m signed up and updated. Still the same issue, are there logs I can send? Also, btw I’m getting blank screen on the macOS app. Its a react error

Element type is invalid: expected a string (for built-in components) or a class/function (for composite components) but got: undefined.

Seems like a parent is not getting a child it expect to render… like the root component since nothing is rendering.


(Takuya Matsuyama) #8

I’ll look into your error logs on Bugsnag.

Sorry for the inconvenience. Please try this patch and let me know if it works:

https://inkdrop-dist.s3-ap-northeast-1.amazonaws.com/tmp/Inkdrop-4.3.1-Mac-patch.zip


(Takuya Matsuyama) #9

I’ve got an error log from the beta app which is:

URIError · String contained an illegal UTF-16 sequence.

This is happening while processing a particular note with encodeURIComponent to calculate MD5 digest.
I will try to reproduce it.
Do you have any idea on it? Something like you’ve wrote special characters in your notes.
Thank you for your cooperation!


(Joe Narvaez`) #10

I found it. It hangs when there is a ZWJ combined emoji in the title (not the body) of the note. It works fine with a regular emoji in the title.


(Takuya Matsuyama) #11

Great to know that! I’ll research how to avoid this problem.